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Consider keeping your video on (if possible)

Kids? Pets? Spouses? No problem

But ultimately, you need be comfortable! (and you absolutely have the right to privacy)

Interrupt me!

Generally keep yourself muted but un-mute anytime to ask questions

Ask Questions!

Group trouble-shooting is really valuable

If you have a problem, others may also (or may have it in the future)

Screen-sharing

I may ask you to share your screen with the group (feel free to decline)

For privacy, close your email etc. Or just share your RStudio window
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My gardenMy garden

6 / 34



What about you?What about you?
Name

Background (Role, Area of study, etc.)

Familiarity with R or Programming

Creatures (furry, feathery, scaley, green or otherwise)?
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Getting StartedGetting Started
Today we’re learning to create static HTML reports from R code

(but can also create websites, pdfs, and presentations–like this one!)

Why?

Keep track of your code and results

Share your work

Ensure reproducibility

Be nice to your future self (What did I do again? What were the results?)

Okay, what kind of report?
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For example…For example…
## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffilazerte/NRI_7350/main/data/chorus.csv")12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22

9 / 34

file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html


Becomes…Becomes…

Setup

This is my great study…. I used these packages:

Loading data

These are the datasets I used

library(tidyverse)1

── Attaching core tidyverse packages ──────────────────────── tidyverse 2.0.0 ──

✔ dplyr     1.1.4     ✔ readr     2.1.5

✔ forcats   1.0.0     ✔ stringr   1.5.1

✔ ggplot2   3.5.2     ✔ tibble    3.3.0

✔ lubridate 1.9.4     ✔ tidyr     1.3.1

✔ purrr     1.1.0     

── Conflicts ────────────────────────────────────────── tidyverse_conflicts() ──

✖ dplyr::filter() masks stats::filter()

✖ dplyr::lag()    masks stats::lag()

ℹ Use the conflicted package (<http://conflicted.r-lib.org/>) to force all conflicts to become errors

my_data <- read_csv(1

  "https://raw.githubusercontent.com/steffilazerte/NRI_7350/main/data/chorus.csv"2

)3

my_data4

# A tibble: 51 × 3

   urbanization songs calls

          <dbl> <dbl> <dbl>

 1        0.794     0   136
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For another example…For another example…

(Plus a bunch of other options)

### Visual of Thresholds Calculations1

2

> - Pink ribbon = 99% Confidence interval of latitudes predicted from GAM3

> - Black lines in the ribbon are the upper and lower limit, the middle4

line is the predicted latitude (from GAM model)5

> - Transparent blue rectangles indicate the date ranges used to establish6

the latitudes just after and just before migration.7

> - Blue horizontal lines represents the latitude threshold for spring 8

    migration (begin/end)9

> - Orange horzontal lines represents the latitude threshold for fall 10

    migration (begin/end)11

12

```{r}13

#| fig-asp: 1 14

#| fig-width: 1515

wrap_plots(g) + plot_layout(guides = "collect", nrow = 1)16

```17
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Becomes…Becomes…
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Wait a minute…Wait a minute…
That doesn’t look like an R Script…
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Not an R script…Not an R script…

Four things going on…

1. R code

2. R code fences (define code chunks)

3. Markdown

4. YAML chunk options

## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffila12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22
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Not an R script…Not an R script…

Four things going on…

1. R code

2. R code fences (define code chunks)

3. Markdown

4. YAML chunk options

## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffila12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22
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This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffila12
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This is what it looks like16

17
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#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22
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  geom_point()21

```22

## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffila12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22

## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffila12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22

This is actually not an .R script…

it’s an R Markdown (.Rmd) or

Quarto (.qmd) document!
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Quick startQuick start
File > New Project

File > New File > Quarto Document (or R Markdown, if you prefer)

Add details, click “Create”

Click “Render” button in the top panel (Quarto)

or “Knit” button (R Markdown)

Demo
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Your TurnYour Turn
Using this RStudio template, add in some code from your own scripts and render it.

Keep it relatively simple for now �
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Your TurnYour Turn
Using this RStudio template, add in some code from your own scripts and render it.

Keep it relatively simple for now �

What just happened? What are all these things?

R Markdown? Markdown? Quarto? YAML §

16 / 34



TerminologyTerminology

R & RStudio

Both are programs

R is the programming language/envrionment

RStudio is an IDE (integrated development environment)

 

R

 

RStudio
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TerminologyTerminology

Markdown

A text markup language

Files are .md

For example, the following… Becomes…

My heading

Hi! This is in italics

A  to R

### My heading1

2

**Hi!** This is in *italics*3

4

A [link](https://cran.r-project.org/) to R5

link

18 / 34

file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
file:///home/user/index.html
https://cran.r-project.org/


TerminologyTerminology

R Markdown, Quarto, knitr, and Pandoc

R Markdown(.Rmd) and Quarto (.qmd) files are a mix of Markdown and R code

knitr is an R package which evaluates R code and returns the output as a Markdown file

Pandoc is a separate (independent) program that converts Markdown to a variety of formats
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TerminologyTerminology

R Markdown, Quarto, knitr, and Pandoc

R Markdown(.Rmd) and Quarto (.qmd) files are a mix of Markdown and R code

knitr is an R package which evaluates R code and returns the output as a Markdown file

Pandoc is a separate (independent) program that converts Markdown to a variety of formats

R Markdown vs.  Quarto

Quarto (.qmd) is the next generation of R Markdown (.Rmd). You can still use R Markdown (it’s not going

anywhere), but Quarto is much newer and more powerful.

19 / 34



TerminologyTerminology

YAML, HTML, CSS/SCSS

20 / 34



TerminologyTerminology

YAML, HTML, CSS/SCSS

YAML is a language for specifying (meta)data

Used for specifying document options/configuration and chunk options
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TerminologyTerminology

YAML, HTML, CSS/SCSS

YAML is a language for specifying (meta)data

Used for specifying document options/configuration and chunk options

HTML is a language for making websites

Can be used directly in .qmd/.Rmd files if you plan to output to HTML

E.g., can use <br\> for a line break

20 / 34



TerminologyTerminology

YAML, HTML, CSS/SCSS

YAML is a language for specifying (meta)data

Used for specifying document options/configuration and chunk options

HTML is a language for making websites

Can be used directly in .qmd/.Rmd files if you plan to output to HTML

E.g., can use <br\> for a line break

CSS is a language for styling websites

Can be used to apply custom styles to documents

SCSS is CSS with superpowers

20 / 34



Some optionsSome options

Document level options - YAML block

date: today to include today’s date

toc: true to include a table of contents

code-fold: true to hide code (with option to show)

---1

title: "My great analysis"2

format: html3

date: today4

toc: true5

code-fold: true6

---7

Note: These are Quarto options! R Markdown has similar ones, but they may be slightly different. E.g.,

format: html_document in R Markdown.

21 / 34
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Some optionsSome options

Chunk level options - YAML notation

fig-width width of figure in inches

fig-asp aspect of the figure (1 = square)

(i.e.  height = width * aspect)

fig-alt Alternative text for screen readers

helping those who can’t see the figure

(should be descriptive, not the same as a

caption)1

fig-cap Figure caption

```{r}1

#| fig-width: 102

#| fig-asp: 0.53

#| fig-alt: |4

#|   A scatterplot in black and white showing degree of 5

#|   urbanization on the x-axis and number of songs on 6

#|   the y-axis with no appreciable pattern in the data.7

#| fig-cap: |8

#|   The relationship between urbanization and the number9

#|   of songs in mountain chickadee dawn choruses.10

11

ggplot(data = my_data, aes(x = urbanization, y = songs)) +12

  geom_point()13

```14

1. More alt text resources: ; ; the when to include how to write importance of context

22 / 34
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Gives…Gives…

The relationship between urbanization and the number of songs in mountain chickadee dawn choruses.

ggplot(data = my_data, aes(x = urbanization, y = songs)) +1

  geom_point()2
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Enhancing reproducibilityEnhancing reproducibility
Create your publication figures through reports

Date your reports (my_analysis_2022-09-08.html)

Include info on packages used (because you’re going to  them… right? RIGHT?)

devtools::session_info()

report::report_packages()

report::cite_packages()

Embed data directly (for smaller datasets) using  package

cite

DT

DT::datatable(mtcars, extensions = 'Buttons',1

              options = list(dom = 'Bfrtip', buttons = c('csv', 'excel')))2

24 / 34
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Cite the Packages!Cite the Packages!
Seriously,  the packages wcite

25 / 34

https://ropensci.org/blog/2021/11/16/how-to-cite-r-and-r-packages/


Your TurnYour Turn
Use the more advanced  (example.qmd) to create a reproducible report of your analysis.

Consider the options we learned

Anything you’d like to add?

Consider code-fold: true or toc: false

template
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https://steffilazerte.ca/intro_to_quarto/example.qmd


Some Final ThoughtsSome Final Thoughts
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Rendering vs.  SpinningRendering vs.  Spinning

Rendering (Render/Knit button)

.Rmd/.qmd → .md → HTML

Spinning (Knit button)

.R → .md → HTML
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Rendering vs.  SpinningRendering vs.  Spinning

Rendering (Render/Knit button)

.Rmd/.qmd → .md → HTML

Spinning (Knit button)

.R → .md → HTML

Good for lots of text

Better option control

Use ```{r}  and ```to define code blocks

Easier to code

Use #'  to define markdown

Use #+  to define chunk options

Use Rmarkdown option style

i.e., error=FALSE  not error: false

28 / 34



Rendering vs.  SpinningRendering vs.  Spinning

Rendering (Render/Knit button)

Or render with:

Spinning (Knit button)

Or spin/render with:

## Setup1

This is my **great** study.... I used these packages:2

3

```{r}4

library(tidyverse)5

```6

7

## Loading data8

These are the datasets I used9

10

```{r}11

my_data <- read_csv("https://raw.githubusercontent.com/steffilaze12

my_data13

```14

15

This is what it looks like16

17

```{r}18

#| fig-width: 619

ggplot(data = my_data, aes(x = urbanization, y = songs)) +20

  geom_point()21

```22

quarto::quarto_render(1

  input = "example.qmd", 2

  output_file = paste0("example_", Sys.Date(), ".html"))3

#' ## Setup1

#' This is my **great** study.... I used these packages:2

3

library(tidyverse)4

5

#' ## Loading data6

#' These are the datasets I used7

8

my_data <- read_csv("https://raw.githubusercontent.com/steffilaze9

my_data10

11

#' This is what it looks like12

13

#+ fig-width = 614

ggplot(data = my_data, aes(x = urbanization, y = songs)) +15

  geom_point()16

knitr::spin("example_spin.R", knit = FALSE)1

quarto::quarto_render(2

  input = "example_spin.Rmd",3

  output_file = paste0("example_spin_", Sys.Date(), ".html"))4

See example_spin.R
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Relative locationsRelative locations
If you use nested folders in your work,

you’ll want to use the  package to ensure

all the file locations are consistent

here

library(here)1

library(tidyverse)2

3

my_data <- read_csv(here("Data/my_data.csv"))4

Artwork by @allison_horst
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Taking it to the next levelTaking it to the next level
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Analysis WebsitesAnalysis Websites

Vulture Migration (  | ) Urban Migration Stopovers (  | )

( )Quarto Docs for Websites

GitHub Website GitHub Website
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https://quarto.org/docs/websites/
https://github.com/steffilazerte/vulture_migration
https://steffilazerte.ca/vulture_migration/
https://github.com/steffilazerte/urban_motus/
https://steffilazerte.ca/urban_motus


Manuscript WebsitesManuscript Websites
Effects of Riparian Grazing on Distinct Water-Extractable Phosphorus Sources (  | )

( )Quarto Docs for Manuscripts

GitHub Website

The manuscript

A notebook associated with the manuscript
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https://quarto.org/docs/manuscripts/
https://github.com/alex-koiter/riparian-grazing-manuscript
https://alexkoiter.ca/riparian-grazing-manuscript/


ResourcesResources

Online References

RStudio > Help > Markdown Quick Reference

Quarto

 (video)

 (blog post)

 (blog)

R Markdown

 (online book)

RStudio > Help > Cheat Sheets > R Markdown Cheat Sheet

RStudio > Help > Cheat Sheets > R Markdown Reference Guide

Examples

Quarto Documentation

Openscapes’ Quarto Tutorial

Posit’s Welcome to Quarto Workshop!

We don’t talk about Quarto

A Quarto tip a day

R Markdown Documentation

R Markdown: The Definitive Guide

This presentation

Quarto Gallery

R Markdown Gallery
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ResourcesResources

Online References

RStudio > Help > Markdown Quick Reference

Quarto

 (video)

 (blog post)

 (blog)

R Markdown

 (online book)

RStudio > Help > Cheat Sheets > R Markdown Cheat Sheet

RStudio > Help > Cheat Sheets > R Markdown Reference Guide

Examples

Quarto Documentation

Openscapes’ Quarto Tutorial

Posit’s Welcome to Quarto Workshop!

We don’t talk about Quarto

A Quarto tip a day

R Markdown Documentation

R Markdown: The Definitive Guide

This presentation

Quarto Gallery

R Markdown Gallery

Thank you!

 

✉ 

steffilazerte.ca

sel@steffilazerte.ca
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